Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #8573
    Les Dickson
    CVRS Member

    I just acquired this Mercury Radio but can’t find any information on it. I see other Mercury Radios on radiomuseum.org but they all seem to use peanut tubes while this has 8 30s and 2 31s.
    Anyone have anything similar? Schematics? Advice? Extravagant Offers?
    The radio came in a case which doesn’t appear to match the radio – although it also is a Mercury. From what I’ve learned these radios may have come as kits.

    #8588
    citco
    Forum Participant

    Hey Les. I also haven’t seen this one before. Are the coils plug in, removable? Kipp did this on the first battery sets but I think fazed that out after a couple of years. This set is certainly at the end of the run. I think they were done in 31. Stuart

    #9123
    Britt Abbott
    Forum Participant

    Hello Les,
    I just got this exact radio off Ebay except mine has the peanut tubes (see photo). Your case is the original case, but your front bakelite panel is missing the wood surround bezel that has a top piece that somewhat locks the chassis in place in the slots. Mine was damaged in shipment from vendor in Canada and I’m trying to put it back together. The worse part are that tube were left unlocked in the sockets and the box was dropped and tube tips it the top of the lid and three of the bakelite bayonet sockets broke where you can’t lock the tubes in place! So, I’m in desperate need of three replacement peanut bakelite tube sockets.

    Let me know if you’re interested in selling, I might be interested.

    Britt
    Chesapeake, VA

    Attachments:
    #9128
    Les Dickson
    CVRS Member

    I watched your radio on eBay, Britt, and say what was missing on my front – as you describe. I think I’ll keep mine for now and try to get it working eventually. What are you doing for a speaker?

    #9129
    Britt Abbott
    Forum Participant

    I have several different 1920 era cone speakers that should work fine with this set once I’m able to find those tube sockets. It’s also missing a knob and shaft for one of the pots.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.